use strict;
my $str = 'приветРегулярка';
my $regex = qr/(?<=[а-яё])(?=[А-ЯЁ])/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";