package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\w+)\[([\w\s]+)\]:([\w\W]+)$`)
var str = `id[varchar]:'текст1 текст2' col_17[varchar]:'текст1 текст2'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}