$re = '/(\w+)\[([\w\s]+)\]:([\w\W]+)$/i';
$str = 'id[varchar]:\'текст1 текст2\' col_17[varchar]:\'текст1 текст2\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);