re = /(\w+)\[([\w\s]+)\]:([\w\W]+)$/i
str = 'id[varchar]:\'текст1 текст2\' col_17[varchar]:\'текст1 текст2\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end