import re
regex = re.compile(r"^net trunk\s+(\S+)[^{]*{.*{ *([^}]*?) *}.*$", flags=re.MULTILINE)
test_str = ("net trunk RandomNameTrunk { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled\n"
"net trunk DifferentNameTrunk { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled\n"
"net trunk trunk#1 { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled\n"
"net trunk trunk#2 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)