re = /^net trunk\s+(\S+)[^{]*{.*{ *([^}]*?) *}.*$/m
str = 'net trunk RandomNameTrunk { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled
net trunk DifferentNameTrunk { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled
net trunk trunk#1 { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled
net trunk trunk#2 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result