using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\W_])(?:Texas|Alabama|Florida)(?![^\W_])";
string input = @"WORKFORCE_2017_ALABAMA_FILE.xlsx
WORKFORCE_2017_FILE.xlsx";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}