const regex = new RegExp('(?<![^\\W_])(?:Texas|Alabama|Florida)(?![^\\W_])', 'gi')
const str = `WORKFORCE_2017_ALABAMA_FILE.xlsx
WORKFORCE_2017_FILE.xlsx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}