$re = '/(?<![^\W_])(?:Texas|Alabama|Florida)(?![^\W_])/i';
$str = 'WORKFORCE_2017_ALABAMA_FILE.xlsx
WORKFORCE_2017_FILE.xlsx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);