package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:([a-zA-Z][a-zA-Z0-9]*)`)
var str = `:hi/:Username@asdfasfasdf:asfs,asdfasfasfs:asdf424/asdfas`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}