re = /:([a-zA-Z][a-zA-Z0-9]*)/
str = ':hi/:Username@asdfasfasdf:asfs,asdfasfasfs:asdf424/asdfas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end