$re = '/:([a-zA-Z][a-zA-Z0-9]*)/';
$str = ':hi/:Username@asdfasfasdf:asfs,asdfasfasfs:asdf424/asdfas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);