using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""".*?""|(\b\S+\b)";
string substitution = @"\1";
string input = @"dbo.test line_length ""quoted words"" notquoted";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}