$re = '/".*?"|(\b\S+\b)/m';
$str = 'dbo.test line_length "quoted words" notquoted';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;