const regex = /".*?"|(\b\S+\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('".*?"|(\\b\\S+\\b)', 'gm')
const str = `dbo.test line_length "quoted words" notquoted`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);