#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\bhref="(.*?)\b")(?!.*\1)?"
Local $sString = " <div>" & @CRLF & _
" <a href="showthread.php?t=5239160" id="thread_title_5239160">программа для точного определения местоположения любого гаджета</a>" & @CRLF & _
" <span class="smallfont" style="white-space:nowrap">(<img class="inlineimg" src="https://static.kharkovforum.com/images/misc/multipage.gif" alt="перейти на страницу" border="0" /> <a href="showthread.php?t=5239160">1</a> <a href="showthread.php?t=5239160&page=2">2</a>)</span>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" <div class="smallfont">" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <span style="cursor:pointer" onclick="window.open('member.php?u=502041', '_self')">I-am</span>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")