use strict;
my $str = ' <div>
<a href="showthread.php?t=5239160" id="thread_title_5239160">программа для точного определения местоположения любого гаджета</a>
<span class="smallfont" style="white-space:nowrap">(<img class="inlineimg" src="https://static.kharkovforum.com/images/misc/multipage.gif" alt="перейти на страницу" border="0" /> <a href="showthread.php?t=5239160">1</a> <a href="showthread.php?t=5239160&page=2">2</a>)</span>
</div>
<div class="smallfont">
<span style="cursor:pointer" onclick="window.open(\'member.php?u=502041\', \'_self\')">I-am</span>
</div>
';
my $regex = qr/(\bhref="(.*?)\b")(?!.*\1)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}