import re
regex = re.compile(r"(\bhref=\"(.*?)\b\")(?!.*\1)?")
test_str = (" <div>\n"
" <a href=\"showthread.php?t=5239160\" id=\"thread_title_5239160\">программа для точного определения местоположения любого гаджета</a>\n"
" <span class=\"smallfont\" style=\"white-space:nowrap\">(<img class=\"inlineimg\" src=\"https://static.kharkovforum.com/images/misc/multipage.gif\" alt=\"перейти на страницу\" border=\"0\" /> <a href=\"showthread.php?t=5239160\">1</a> <a href=\"showthread.php?t=5239160&page=2\">2</a>)</span>\n"
" </div>\n\n"
" \n\n"
" <div class=\"smallfont\">\n"
" \n"
" \n"
" <span style=\"cursor:pointer\" onclick=\"window.open('member.php?u=502041', '_self')\">I-am</span>\n"
" \n"
" </div>\n\n"
" \n\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")