#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)(?<!-)\b(\w{6})\b(?!-)"
Local $sString = "В результате получим функциональность файла hosts с дополнительными плюшками: " & @CRLF & _
"" & @CRLF & _
"Файл hosts кэшируется, иногда приходится несколько раз нажимать Ctrl+F5, чтобы увидеть изменения. Правила из конфига Yaxy применяются сразу после сохранения." & @CRLF & _
"Локальность. Файл hosts влияет™ на всю систему, через проксю™ же ходят только нужные вам браузеры. Хотя в некоторых случаях это может быть недостатком." & @CRLF & _
"А у вас есть виртуальные машины с различными браузерами в них? В каждой виртуальной машине приходится поддерживать файл hosts. А можно просто™ прописать всем браузерам один прокси-сервер." & @CRLF & _
"Вы проверяете свои сайты в iPhone™/iPad? Хорошо™, если есть девелоперский сервер, а если нет — приходится олаживаться в продакшне. С Yaxy мы указываем в настройках прокси-сервер на нашем локальном компьютере и смотрим с телефона все локальные сайты." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")