$re = '/(?<!-)\b(\w{6})\b(?!-)/miu';
$str = 'В результате получим функциональность файла hosts с дополнительными плюшками:
Файл hosts кэшируется, иногда приходится несколько раз нажимать Ctrl+F5, чтобы увидеть изменения. Правила из конфига Yaxy применяются сразу после сохранения.
Локальность. Файл hosts влияет™ на всю систему, через проксю™ же ходят только нужные вам браузеры. Хотя в некоторых случаях это может быть недостатком.
А у вас есть виртуальные машины с различными браузерами в них? В каждой виртуальной машине приходится поддерживать файл hosts. А можно просто™ прописать всем браузерам один прокси-сервер.
Вы проверяете свои сайты в iPhone™/iPad? Хорошо™, если есть девелоперский сервер, а если нет — приходится олаживаться в продакшне. С Yaxy мы указываем в настройках прокси-сервер на нашем локальном компьютере и смотрим с телефона все локальные сайты.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);