import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!-)\\b(\\w{6})\\b(?!-)";
final String string = "В результате получим функциональность файла hosts с дополнительными плюшками: \n\n"
+ "Файл hosts кэшируется, иногда приходится несколько раз нажимать Ctrl+F5, чтобы увидеть изменения. Правила из конфига Yaxy применяются сразу после сохранения.\n"
+ "Локальность. Файл hosts влияет™ на всю систему, через проксю™ же ходят только нужные вам браузеры. Хотя в некоторых случаях это может быть недостатком.\n"
+ "А у вас есть виртуальные машины с различными браузерами в них? В каждой виртуальной машине приходится поддерживать файл hosts. А можно просто™ прописать всем браузерам один прокси-сервер.\n"
+ "Вы проверяете свои сайты в iPhone™/iPad? Хорошо™, если есть девелоперский сервер, а если нет — приходится олаживаться в продакшне. С Yaxy мы указываем в настройках прокси-сервер на нашем локальном компьютере и смотрим с телефона все локальные сайты.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}