const regex = /\b5\*14\b[\s\S]*?\b(\d+\.\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b5\\*14\\b[\\s\\S]*?\\b(\\d+\\.\\d+)', '')
const str = `120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}