re = /\b5\*14\b[\s\S]*?\b(\d+\.\d+)/
str = '120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH'
# Print the match result
str.match(re) do |match|
puts match.to_s
end