import re
regex = re.compile(r"\b5\*14\b[\s\S]*?\b(\d+\.\d+)")
test_str = ("120.65UAH Produkti Kvartal\n"
"5*14 14:24\n"
"Bal. 16603.52UAH")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")