using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"='(\{?\$.+?)(?:'(?:\s|;))";
string input = @"""SELECT * FROM `users` WHERE user='$user' AND password='$pass';"";
(""SELECT table_schema, table_name, create_time FROM information_schema.tables WHERE table_schema='{$_DVWA['db_database']}' AND table_name='users' LIMIT 1"");";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}