const regex = new RegExp('=\\'(\\{?\\$.+?)(?:\\'(?:\\s|;))', 'g')
const str = `"SELECT * FROM \`users\` WHERE user='\$user' AND password='\$pass';";
("SELECT table_schema, table_name, create_time FROM information_schema.tables WHERE table_schema='{\$_DVWA['db_database']}' AND table_name='users' LIMIT 1");`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}