re = /='(\{?\$.+?)(?:'(?:\s|;))/
str = '"SELECT * FROM `users` WHERE user=\'$user\' AND password=\'$pass\';";
("SELECT table_schema, table_name, create_time FROM information_schema.tables WHERE table_schema=\'{$_DVWA[\'db_database\']}\' AND table_name=\'users\' LIMIT 1");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end