using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<imei>[^,]*),(?<gaid>[^,]*),(?<session>[^,]*),(?<action_time>[^,]*),(?<action>[^,]*),'(?<attrs>\{[^']*\})','(?<impressions>[^']*)'";
string input = @"45235g4tgd3453452,89789dsjfhwf897897fsd9sd,123456789-82638273-92DA5F569,2016-06-12 06:10:03,4000,'{""ref_action"":""3000"",""result"":""500"",""pfx"":""gb""}','{""1000"":""3"",""34567"":""14""}'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}