const regex = /(?<imei>[^,]*),(?<gaid>[^,]*),(?<session>[^,]*),(?<action_time>[^,]*),(?<action>[^,]*),'(?<attrs>\{[^']*\})','(?<impressions>[^']*)'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<imei>[^,]*),(?<gaid>[^,]*),(?<session>[^,]*),(?<action_time>[^,]*),(?<action>[^,]*),\'(?<attrs>\\{[^\']*\\})\',\'(?<impressions>[^\']*)\'', 'g')
const str = `45235g4tgd3453452,89789dsjfhwf897897fsd9sd,123456789-82638273-92DA5F569,2016-06-12 06:10:03,4000,'{"ref_action":"3000","result":"500","pfx":"gb"}','{"1000":"3","34567":"14"}'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}