$re = '/(?<imei>[^,]*),(?<gaid>[^,]*),(?<session>[^,]*),(?<action_time>[^,]*),(?<action>[^,]*),\'(?<attrs>\{[^\']*\})\',\'(?<impressions>[^\']*)\'/';
$str = '45235g4tgd3453452,89789dsjfhwf897897fsd9sd,123456789-82638273-92DA5F569,2016-06-12 06:10:03,4000,\'{"ref_action":"3000","result":"500","pfx":"gb"}\',\'{"1000":"3","34567":"14"}\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);