#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\bfrom\b(?:\s*#\w+(?:\s*\w+))*+|(?!^)\G),?\s*\K(?!(?:\w+ )?\bwhere\b)([\w ]+)(?=[^w]*(?:\bw(?!here\b)[^w]*)*\bwhere\b)"
Local $sString = "select ... from course" & @CRLF & _
"where ..." & @CRLF & _
" " & @CRLF & _
"select ... from course c, marks s" & @CRLF & _
"where ...." & @CRLF & _
"" & @CRLF & _
"select ... from #prefix#course c, marks m" & @CRLF & _
"where ..." & @CRLF & _
"" & @CRLF & _
"select ... from #prefix#course c" & @CRLF & _
"where id = (select ... from student s where ...)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")