$re = '/(?:\bfrom\b(?:\s*#\w+(?:\s*\w+))*+|(?!^)\G),?\s*\K(?!(?:\w+ )?\bwhere\b)([\w ]+)(?=[^w]*(?:\bw(?!here\b)[^w]*)*\bwhere\b)/';
$str = 'select ... from course
where ...
select ... from course c, marks s
where ....
select ... from #prefix#course c, marks m
where ...
select ... from #prefix#course c
where id = (select ... from student s where ...)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);