import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bfrom\\b(?:\\s*#\\w+(?:\\s*\\w+))*+|(?!^)\\G),?\\s*\\K(?!(?:\\w+ )?\\bwhere\\b)([\\w ]+)(?=[^w]*(?:\\bw(?!here\\b)[^w]*)*\\bwhere\\b)";
final String string = "select ... from course\n"
+ "where ...\n"
+ " \n"
+ "select ... from course c, marks s\n"
+ "where ....\n\n"
+ "select ... from #prefix#course c, marks m\n"
+ "where ...\n\n"
+ "select ... from #prefix#course c\n"
+ "where id = (select ... from student s where ...)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}