#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Aankomst:\sMAANDAG\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|dinsdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|woensdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|donderdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|vrijdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|zaterdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|zondag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:"
Local $sString = " +++++++++++++++++++++++++++++++++++++++++++++++" & @CRLF & _
" + Ref Document: 137165 +" & @CRLF & _
" +++++++++++++++++++++++++++++++++++++++++++++++" & @CRLF & _
"From: jamirequest@jetair.be" & @CRLF & _
"emaildestin;L ;137165;yourname" & @CRLF & _
"" & @CRLF & _
"jetair@groupepvcp.com" & @CRLF & _
"CENTER PARCS ERPERHEIDE Uw code: 78154 / BLI" & @CRLF & _
" Datum: 18/11/15" & @CRLF & _
" ***** Reservering in allotment *****" & @CRLF & _
"Reserveringsnummer: 021146151 SJ Reserveringsdatum: 18/11/2015" & @CRLF & _
"" & @CRLF & _
"Gelieve de volgende reservering te noteren aub aan contractprijs" & @CRLF & _
"" & @CRLF & _
"Aankomst: zondag 01/02/2016 Vertrek: vrijdag 05/02/2016 4 Nachten." & @CRLF & _
"" & @CRLF & _
" 1 x type 30: EP082 app. 2 pers. comfort" & @CRLF & _
" Bad of douche, Terras, TV, Kitchenette" & @CRLF & _
" In allotment" & @CRLF & _
" Logies" & @CRLF & _
" MIDWEEKVERBLIJF" & @CRLF & _
" 01/02/16 - 05/02/16" & @CRLF & _
" EARLY BOOKING" & @CRLF & _
"" & @CRLF & _
" Mr. D.DEBERGH 28 jaar" & @CRLF & _
" Mevr. S.BOUDEN 25 jaar" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Het is niet nodig deze reservering te herbevestigen" & @CRLF & _
"" & @CRLF & _
"Opmerkingen/speciale wensen" & @CRLF & _
" indien mogelijk babybed" & @CRLF & _
"" & @CRLF & _
"cpref,021146151,..." & @CRLF & _
"Einde van het bericht"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")