// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)Aankomst:\sMAANDAG\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|dinsdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|woensdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|donderdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|vrijdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|zaterdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|zondag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:").unwrap();
let string = " +++++++++++++++++++++++++++++++++++++++++++++++
+ Ref Document: 137165 +
+++++++++++++++++++++++++++++++++++++++++++++++
From: jamirequest@jetair.be
emaildestin;L ;137165;yourname
jetair@groupepvcp.com
CENTER PARCS ERPERHEIDE Uw code: 78154 / BLI
Datum: 18/11/15
***** Reservering in allotment *****
Reserveringsnummer: 021146151 SJ Reserveringsdatum: 18/11/2015
Gelieve de volgende reservering te noteren aub aan contractprijs
Aankomst: zondag 01/02/2016 Vertrek: vrijdag 05/02/2016 4 Nachten.
1 x type 30: EP082 app. 2 pers. comfort
Bad of douche, Terras, TV, Kitchenette
In allotment
Logies
MIDWEEKVERBLIJF
01/02/16 - 05/02/16
EARLY BOOKING
Mr. D.DEBERGH 28 jaar
Mevr. S.BOUDEN 25 jaar
Het is niet nodig deze reservering te herbevestigen
Opmerkingen/speciale wensen
indien mogelijk babybed
cpref,021146151,...
Einde van het bericht";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}