import re
regex = re.compile(r"Aankomst:\sMAANDAG\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|dinsdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|woensdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|donderdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|vrijdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|zaterdag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:|zondag\s([0-9][0-9]\/[0-9][0-9]\/[0-9][0-9][0-9][0-9])\s\s\s\sVertrek:", flags=re.IGNORECASE)
test_str = (" +++++++++++++++++++++++++++++++++++++++++++++++\n"
" + Ref Document: 137165 +\n"
" +++++++++++++++++++++++++++++++++++++++++++++++\n"
"From: jamirequest@jetair.be\n"
"emaildestin;L ;137165;yourname\n\n"
"jetair@groupepvcp.com\n"
"CENTER PARCS ERPERHEIDE Uw code: 78154 / BLI\n"
" Datum: 18/11/15\n"
" ***** Reservering in allotment *****\n"
"Reserveringsnummer: 021146151 SJ Reserveringsdatum: 18/11/2015\n\n"
"Gelieve de volgende reservering te noteren aub aan contractprijs\n\n"
"Aankomst: zondag 01/02/2016 Vertrek: vrijdag 05/02/2016 4 Nachten.\n\n"
" 1 x type 30: EP082 app. 2 pers. comfort\n"
" Bad of douche, Terras, TV, Kitchenette\n"
" In allotment\n"
" Logies\n"
" MIDWEEKVERBLIJF\n"
" 01/02/16 - 05/02/16\n"
" EARLY BOOKING\n\n"
" Mr. D.DEBERGH 28 jaar\n"
" Mevr. S.BOUDEN 25 jaar\n\n\n"
"Het is niet nodig deze reservering te herbevestigen\n\n"
"Opmerkingen/speciale wensen\n"
" indien mogelijk babybed\n\n"
"cpref,021146151,...\n"
"Einde van het bericht")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")