const regex = /(?|([a-zA-Z0-9]+)[({[«]([a-zA-Z\s]+)[)}\]»]|[({[«]([a-zA-Z\s]+)[)}\]»]([a-zA-Z0-9]+))|[({[«]([a-zA-Z0-9]+)(?!\S)|(?<!\S)([a-zA-Z0-9]+)[)}\]»]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|([a-zA-Z0-9]+)[({[«]([a-zA-Z\\s]+)[)}\\]»]|[({[«]([a-zA-Z\\s]+)[)}\\]»]([a-zA-Z0-9]+))|[({[«]([a-zA-Z0-9]+)(?!\\S)|(?<!\\S)([a-zA-Z0-9]+)[)}\\]»]', 'g')
const str = `// i want to mark for single brackets examples below other heighlight pattren not disturb.please
(weather // i want to mark this word
weather) // i want to mark this word
(weather is good // i want to mark this word
weather is good) // i want to mark this word
weathe)r
wea(ther
and same for other brackets {,[,«
{weather // i want to mark this word
weather} // i want to mark this word
{weather is good // i want to mark this word
weather is good} // i want to mark this word
weathe}r // i want to mark this word
weathe{r // i want to mark this word
[weather // i want to mark this word
weather] // i want to mark this word
[weather is good // i want to mark this word
weather is good] // i want to mark this word
weathe]r // i want to mark this word
weathe[r // i want to mark this word
«weather // i want to mark this word
weather} // i want to mark this word
«weather is good // i want to mark this word
weather is good» // i want to mark this word
weathe»r // i want to mark this word
weathe»r // i want to mark this word
(Weather) is good. // not need to mark this beacuase this word correct word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // mark
(weath)er // mark
weather(is fine)
weather is good
{weather is good} //not need to mark correct
weat{er is good} // mark
we{ather} is fine // mark
{weathe}r is fine // i want to mark this word
{weather is fin}e // i want to mark this word
[weather is good] //not need to mark correct
weat[her is good] // mark
we[ather] is fine // mark
[weathe]r is fine // mark
[weather is f]ine // mark
we[ather] is fine // mark
«weather is good» //not need to mark
weat«her is good» // mark
we«ather» is fine // mark
«weat»her is fine // mark
«weather is fi»ne // mark
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}