# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?|([a-zA-Z0-9]+)[({[«]([a-zA-Z\s]+)[)}\]»]|[({[«]([a-zA-Z\s]+)[)}\]»]([a-zA-Z0-9]+))|[({[«]([a-zA-Z0-9]+)(?!\S)|(?<!\S)([a-zA-Z0-9]+)[)}\]»]"
test_str = ("// i want to mark for single brackets examples below other heighlight pattren not disturb.please\n"
"(weather // i want to mark this word\n"
"weather) // i want to mark this word\n"
"(weather is good // i want to mark this word\n"
"weather is good) // i want to mark this word\n"
"weathe)r\n"
"wea(ther\n"
"and same for other brackets {,[,«\n"
"{weather // i want to mark this word\n"
"weather} // i want to mark this word\n"
"{weather is good // i want to mark this word\n"
"weather is good} // i want to mark this word\n"
"weathe}r // i want to mark this word\n"
"weathe{r // i want to mark this word\n\n"
"[weather // i want to mark this word\n"
"weather] // i want to mark this word\n"
"[weather is good // i want to mark this word\n"
"weather is good] // i want to mark this word\n"
"weathe]r // i want to mark this word\n"
"weathe[r // i want to mark this word\n"
"«weather // i want to mark this word\n"
"weather} // i want to mark this word\n"
"«weather is good // i want to mark this word\n"
"weather is good» // i want to mark this word\n"
"weathe»r // i want to mark this word\n"
"weathe»r // i want to mark this word\n\n"
"(Weather) is good. // not need to mark this beacuase this word correct word\n"
"Weath(er) is good. // mark\n"
"Weath(er is good). // mark\n"
"Weather (is) (good).\n"
"My name is Rah(eel) // mark\n"
"Best pro(duct) // mark\n"
"(Weather is good) // not need to mark this beacuase this word konown word\n"
"we(ather)\n"
"(weath)er is good. // mark\n"
"(weath)er // mark\n"
"weather(is fine)\n"
"weather is good\n"
"{weather is good} //not need to mark correct\n"
"weat{er is good} // mark\n"
"we{ather} is fine // mark\n\n"
"{weathe}r is fine // i want to mark this word\n"
"{weather is fin}e // i want to mark this word\n\n"
"[weather is good] //not need to mark correct\n"
"weat[her is good] // mark\n"
"we[ather] is fine // mark\n\n"
"[weathe]r is fine // mark\n"
"[weather is f]ine // mark\n\n"
"we[ather] is fine // mark\n\n"
"«weather is good» //not need to mark\n"
"weat«her is good» // mark\n\n"
"we«ather» is fine // mark\n\n"
"«weat»her is fine // mark\n"
"«weather is fi»ne // mark\n\n\n\n\n\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.