use strict;
my $str = '// i want to mark for single brackets examples below other heighlight pattren not disturb.please
(weather // i want to mark this word
weather) // i want to mark this word
(weather is good // i want to mark this word
weather is good) // i want to mark this word
weathe)r
wea(ther
and same for other brackets {,[,«
{weather // i want to mark this word
weather} // i want to mark this word
{weather is good // i want to mark this word
weather is good} // i want to mark this word
weathe}r // i want to mark this word
weathe{r // i want to mark this word
[weather // i want to mark this word
weather] // i want to mark this word
[weather is good // i want to mark this word
weather is good] // i want to mark this word
weathe]r // i want to mark this word
weathe[r // i want to mark this word
«weather // i want to mark this word
weather} // i want to mark this word
«weather is good // i want to mark this word
weather is good» // i want to mark this word
weathe»r // i want to mark this word
weathe»r // i want to mark this word
(Weather) is good. // not need to mark this beacuase this word correct word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // mark
(weath)er // mark
weather(is fine)
weather is good
{weather is good} //not need to mark correct
weat{er is good} // mark
we{ather} is fine // mark
{weathe}r is fine // i want to mark this word
{weather is fin}e // i want to mark this word
[weather is good] //not need to mark correct
weat[her is good] // mark
we[ather] is fine // mark
[weathe]r is fine // mark
[weather is f]ine // mark
we[ather] is fine // mark
«weather is good» //not need to mark
weat«her is good» // mark
we«ather» is fine // mark
«weat»her is fine // mark
«weather is fi»ne // mark
';
my $regex = qr/(?|([a-zA-Z0-9]+)[({[«]([a-zA-Z\s]+)[)}\]»]|[({[«]([a-zA-Z\s]+)[)}\]»]([a-zA-Z0-9]+))|[({[«]([a-zA-Z0-9]+)(?!\S)|(?<!\S)([a-zA-Z0-9]+)[)}\]»]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}