const regex = /^pimp ([qac]) (\d+)(?: ((?:\w[\w\d\-]+(?: |$))*)(?:"([^"]+)")?)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^pimp ([qac]) (\\d+)(?: ((?:\\w[\\w\\d\\-]+(?: |$))*)(?:"([^"]+)")?)?$', '')
const str = `pimp q 1234 php sql test more "An optional message"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}