$re = '/^pimp ([qac]) (\d+)(?: ((?:\w[\w\d\-]+(?: |$))*)(?:"([^"]+)")?)?$/';
$str = 'pimp q 1234 php sql test more "An optional message"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);