re = /^pimp ([qac]) (\d+)(?: ((?:\w[\w\d\-]+(?: |$))*)(?:"([^"]+)")?)?$/
str = 'pimp q 1234 php sql test more "An optional message"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end