package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([[:blank:]]+(my)*?[[:blank:]]+?\$(\w)*?[[:blank:]]*=[[:blank:]]*(q+\||\"|\')(\w|\W)*?(\||\"|\')(\;))`)
var str = ` my $testql = q|
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
|;
$sql = q|
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
|;
$sql = "
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
";
$sql = '
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
';
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}