use strict;
my $str = ' my $testql = q|
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
|;
$sql = q|
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
|;
$sql = "
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
";
$sql = \'
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
\';
';
my $regex = qr/([[:blank:]]+(my)*?[[:blank:]]+?\$(\w)*?[[:blank:]]*=[[:blank:]]*(q+\||\"|\')(\w|\W)*?(\||\"|\')(\;))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}