$re = '/([[:blank:]]+(my)*?[[:blank:]]+?\$(\w)*?[[:blank:]]*=[[:blank:]]*(q+\||\"|\')(\w|\W)*?(\||\"|\')(\;))/m';
$str = ' my $testql = q|
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
|;
$sql = q|
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
|;
$sql = "
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
";
$sql = \'
select l.listing_type_id, l.listing_package_id, l.paid, l.active, l.tap_print_lines
from listing l
where l.id = ?
\';
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);