using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0x[0-9a-f]{13}";
string input = @"0xaaaabbbbffffd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}