package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0x[0-9a-f]{13}`)
var str = `0xaaaabbbbffffd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}