$re = '/0x[0-9a-f]{13}/';
$str = '0xaaaabbbbffffd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);