import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^)]*I{3}[^)]*\\)";
final String string = "115 There was objective evidence to establish that the enactment of national laws for various mandatory IMO instruments and their amendments (including tacit amendments) were subject to delays and there was a lack of established procedures and commitment from relevant authorities to assist the process (SOLAS 1974, article I; MARPOL, article 1; LL 1966, article 1; III Code, paragraph 4; III Code, paragraph 8; III Code, paragraph 11).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}