# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\([^)]*I{3}[^)]*\)"
test_str = "115 There was objective evidence to establish that the enactment of national laws for various mandatory IMO instruments and their amendments (including tacit amendments) were subject to delays and there was a lack of established procedures and commitment from relevant authorities to assist the process (SOLAS 1974, article I; MARPOL, article 1; LL 1966, article 1; III Code, paragraph 4; III Code, paragraph 8; III Code, paragraph 11)."
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.